Maven settings pointing to your own nexus server in Windows 10

You have your own nexus server running. You want to tell Maven about it.

Update the maven settings at

/[your Windows home directory]/.m2/settings.xml

Contents of settings.xml should look like

<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
http://maven.apache.org/xsd/settings-1.0.0.xsd">

    <mirrors>
        <mirror>
            <id>nexus</id>
            <mirrorOf>*</mirrorOf>

            <url>http://your.nexusServer.com/content/repositories/public</url>
        </mirror>
    </mirrors>

    <servers>
        <server>
            <id>nexus</id>
            <username>yourUsername</username>
            <password>yourPassword</password>
        </server>
    </servers>

    <pluginGroups>
        <pluginGroup>com.sonatype.maven.plugins</pluginGroup>
        <pluginGroup>org.sonatype.plugins</pluginGroup>
    </pluginGroups>

    <profiles>
        <profile>
            <id>nexus</id>
            <repositories>
                <repository>
                    <id>central</id>
                    <url>http://central</url>
                    <releases>
                        <enabled>true</enabled>
                    </releases>
                    <snapshots>
                        <enabled>true</enabled>
                    </snapshots>
                </repository>
            </repositories>
            <pluginRepositories>
                <pluginRepository>
                    <id>central</id>
                    <url>http://central</url>
                    <releases>
                        <enabled>true</enabled>
                    </releases>
                    <snapshots>
                        <enabled>true</enabled>
                    </snapshots>
                </pluginRepository>
            </pluginRepositories>
        </profile>
    </profiles>

    <activeProfiles>
        <activeProfile>nexus</activeProfile>
    </activeProfiles>
</settings>

Once you have this working, update the password to encrypt it. But do not start out that way. Get it all working first.